Use sys/xattr.h instead of attr/xattr.h
[platform/upstream/net-tools.git] / RPM / net-tools.spec
1 Summary: Basic Networking Tools
2 Name: net-tools
3 Version: 1.50
4 Release: 1
5 Copyright: GPL
6 Group: Networking/Admin
7 Source: http://www.tazenda.demon.co.uk/phil/net-tools/net-tools-%{version}.tar.gz
8 Patch0: net-tools-1.45-config.patch
9 BuildRoot: /var/tmp/%{name}-root
10
11 %description
12 This is a collection of the basic tools necessary for setting up networking
13 on a Linux machine. It includes ifconfig, route, netstat, rarp, and
14 various other tools.
15
16 %prep
17 %setup  -q
18 %patch0 -p1 -b .config
19
20 %build
21 make
22
23 %install
24 rm -rf $RPM_BUILD_ROOT
25 mkdir -p $RPM_BUILD_ROOT/bin
26 mkdir -p $RPM_BUILD_ROOT/sbin
27 mkdir -p $RPM_BUILD_ROOT/usr/man/man1
28 mkdir -p $RPM_BUILD_ROOT/usr/man/man5
29 mkdir -p $RPM_BUILD_ROOT/usr/man/man8
30
31 make BASEDIR=$RPM_BUILD_ROOT install
32
33 ( cd $RPM_BUILD_ROOT/sbin
34   strip arp ifconfig rarp route slattach plipconfig ipmaddr iptunnel
35   cd ../bin
36   strip hostname netstat
37
38
39 %clean
40 rm -rf $RPM_BUILD_ROOT
41
42 %files
43 %defattr(-,root,root)
44 /sbin/arp
45 /sbin/ifconfig
46 /sbin/rarp
47 /sbin/route
48 /sbin/slattach
49 /sbin/plipconfig
50 /sbin/ipmaddr
51 /sbin/iptunnel
52 /bin/domainname
53 /bin/dnsdomainname
54 /bin/hostname
55 /bin/netstat
56 /bin/nisdomainname
57 /bin/ypdomainname
58 /usr/man/man[158]/*
59 /usr/man/pt_BR/man[18]/*
60 /usr/man/fr_FR/man[18]/*
61 /usr/share/locale/*/LC_MESSAGES/net-tools.mo
62
63 %changelog
64 * Sun Jan 10 1999 Phil Blundell <philb@gnu.org>
65 - update to 1.50
66 - add new stuff to %files and strip it in %install
67
68 * Thu Nov 26 1998 Phil Blundell <pb@nexus.co.uk>
69 - update to 1.48.
70
71 * Thu Nov 12 1998 Jeff Johnson <jbj@redhat.com>
72 - update to 1.47.
73
74 * Wed Sep  2 1998 Jeff Johnson <jbj@redhat.com>
75 - update to 1.46
76
77 * Thu Jul  9 1998 Jeff Johnson <jbj@redhat.com>
78 - build root
79 - include ethers.5
80
81 * Thu Jun 11 1998 Aron Griffis <agriffis@coat.com>
82 - upgraded to 1.45
83 - patched hostname.c to initialize buffer
84 - patched ax25.c to use kernel headers
85
86 * Fri May 01 1998 Prospector System <bugs@redhat.com>
87 - translations modified for de, fr, tr
88
89 * Fri Feb 27 1998 Jason Spangler <jasons@usemail.com>
90 - added config patch
91
92 * Fri Feb 27 1998 Jason Spangler <jasons@usemail.com>
93 - changed to net-tools 1.432
94 - removed old glibc 2.1 patch
95  
96 * Wed Oct 22 1997 Erik Troan <ewt@redhat.com>
97 - added extra patches for glibc 2.1
98
99 * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
100 - included complete set of network protocols (some were removed for
101   initial glibc work)
102
103 * Wed Sep 03 1997 Erik Troan <ewt@redhat.com>
104 - updated glibc patch for glibc 2.0.5
105
106 * Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
107 - built against glibc
108 - updated to 1.33